Resolved
The last error from this incident happened more than 30 minutes ago; RCA in progress.
Monitoring
We've identified the issue, landed mitigations, and seeing recovery.
Investigating
We're seeing elevated latency across our product. Team investigating now.