No components marked as affected
Resolved
We fixed the issue causing a delay in contacting Google LSA leads. Lead processing has now caught up.
Identified
We have identified a cause of the delay in contacting Google LSA leads and are working to mitigate the issue
Investigating
We are investigating delays contacting Google LSA leads