Resolved
All Coach calls from today have been processed.
Monitoring
Coach calls are coming through again. We're actively monitoring as we work through today's remaining backlog and will confirm once everything is fully caught up.
Investigating
We've identified an issue affecting call processing today for Coach calls only. Coach calls from today may currently be delayed. Our team has identified the root cause and is applying a fix now. Processing should resume within the next few minutes, though it may take a few hours for all delayed calls to fully catch up. No action is needed on your end — we'll update this incident once processing is fully caught up. We apologize for the disruption.