Resolved
All systems are back to normal and any delayed bookings and calls have fully caught up.
Monitoring
The impact was limited to delays in booking appointments, and you may see some calls appear on the dashboard later than usual. Live calls were not affected.
Monitoring
We experienced a brief processing delay caused by one of our vendors. A fix has been implemented, and we are monitoring recovery.