A fix has been deployed. Calls should now load correctly in the dashboard and call links should work again.
This issue affected dashboard display only — inbound calls continued to be received. We are monitoring to confirm everything is stable.
Resolved
A fix has been deployed. Calls should now load correctly in the dashboard and call links should work again.
This issue affected dashboard display only — inbound calls continued to be received. We are monitoring to confirm everything is stable.
Investigating
We are investigating an issue where calls are not appearing in the Avoca dashboard Calls page and call links are broken. Some customers have also reported calls not booking into ServiceTitan and inbound calls not coming through.
We are actively investigating and will provide another update.