Resolved
This incident has been fully resolved and inbound call connection rates have returned to normal.
Monitoring
We have observed recovery and are seeing call connection rates return to normal. We are continuing to monitor for stability.
Investigating
We've identified an issue with an upstream provider causing some calls to fail prematurely. Working with them on a resolution with priority.