Resolved
Systems have been showing normal for days, marking resolved.
Monitoring
We've landed another workaround that should help tool calls feel faster and more reliable. Releasing gradually to teams.
Monitoring
We've landed a mitigation that should resolve the issue for most calls. Looking into long term fix now.
Identified
We've identified ServiceTitan API timeouts as a source of tool calls timing out across tenants. Currently working on a mitigation to avoid poor conversational experiences due to long tool calls, and working with the ST team to root cause and fix.