Resolved
We've verified that the upstream provider is now fully operational.
Monitoring
Issue from vendor is reported to be recovering. We've observed stability on our side for now. Will update again when upstream stability is confirmed.
Investigating
Some inbound phone calls are not connecting. Investigating root cause now.